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Commands of the File Menue

Open Load a picture from disk
Close Close the active window
Save Save content of active window
Quit Quit LuraWave



Commands of the View Menu

Symbolbar Switches the Toolbar on and off
        
Statusbar

Switches the statusbar on and off

Commands of the Window Menu

New Creates a new view of the active picture
Stacker Displays windows in a stacked manner
Tile vertical Displays windows in a vertical manner
Tile horizontal Displays windows beside each other
Clean up Symbols Cleans up all symbols
Window 1, 2, ... Activate the choosen window

Commands of the Picture Menu

Copy Copies the frontmost picture to the clipboard
Paste Paste content of the clipboard into a new window
Zoom in Zooms the picture in the frontmost window
Zoom out Shrink the picture in the frontmost window
Info Shows some information about the aktive picture



Commands of the Help Menu

Themes Shows the help directory
Context Switches into context help
Info Shows up version information

Open (File Menu)

Use this command to open a picture within a new window. You can open multiple windows at the same 
time. You can switch between open pictures by using the Window menu. See Window 1,2,...

Shortcut

Toolbar:
Keyboard: STRG+O



The Dialog “File Open”

The following options are available if you like to open a picture.

Filename
Type a filename or select one out of the list. In the list you will find all pictures of the type 
specified in “Filetype”

Filetype
Choose the type of picture you like to open:
· LWF LuraWave Wavelet Format
· BMP_ Windows / OS2 Bitmap
· PGM_ Portable Gray-Map
· PPM Portable Pixel-Map
· TIF_ Tagged Image File Format

Volumes
Choose a volume from wich you like to load the file.

Directory
Choose the directory from where you like to load the picture.

Network...
Use this button to connect a networkvolume to one of you drive-letters.

Preview
If you have marked this checkbox, you will see a small preview image of the
choosen file.

Options
If you select a file compressed in LuraWave format, you can specifiy some
special option like the loading rate here and version number.

Info
You can see the size, colordepth and filesize of the selected file here.



The Close command (Menu File)

Use this command to close the topmost window

You can use the close symbol also.



The Save command (Menu File)

Use this command to save the content of the frontmost window. You will get a dialog in which you can 
choose a format in which the picture should be converted and saved.

Shortcut

Toolbar:
Keyboard: STRG+S



The Dialog “Save” 

Filename
Enter a filename. A extension will be appended by LuraWave.

Volumes
Choose a volume to store the file.

Directory
Choose a directory to store the file.

Network...
Choose this button to assign a new volume-letter to a remote volume.

Options
Choose a option. Options available depend on the choosen filetype:

· LuraWave Wavelet Format(*.lwf)
Version 1.5 The image will be compressed using the older version 1.5 of 

the LuraWave software 
Version 2.0 The image will be compressed using the new version 2.0 of 

the LuraWave software.
Lossless The picture will be compressed perfect, “lossless”
Rate The picture will be compressed with the given rate.

Los in picture quality may occur.

· Windows / OS2 Bitmap (*.bmp)
No options

· Portable Gray- or Pixmap (*.pgm;*ppm)
Binary Picture will be stored in binary format
ASCII Picture will be stored in ASCII format (Readable by a text 

editor)

· Tagged Image File Format (*.tif)
Compression:

non Picture is stored uncompressed
LZW Picture is compressed using the Lempel-Zif-algorithm
Macintosh RLE Picture is compressed using Apples “Macintosh RLE” 

runlength coding.

Commands 1, 2, 3, 4 (Menu File)

In this places you can see the names of the last four opened files. You can reopen the file by choosing the 
appropriate number.



Command Quit (Menu File)

Choose this command to close all pictures and quit the application. LuraWave will ask you to save 
unsaved pictures.

Shortcuts
Mouse: Doubleclick in the upper left corner of the window.

Keyboard: ALT+F4



Command Cut (Menu Edit)

This command cuts a selected area of a picture out of the frame and places the data into the clipboard.
You can use this command only if a area or a whole picture is selected. You can select a area by dragging 
a frame around it. 

Shortcuts

Toolbar:
Keyboard: STRG+X



Command Copy (Menu Edit)

This command will copy the frontmost picture into the clipboard.

Shortcuts

Toolbar:
Keyboard: STRG+C



Command Paste (Menu Edit)

If there is a picture in the clipboard, it is opened in a new window.

Shortcuts

Toolbar:
Keyboard: STRG+V



Command Symbols (Menu View) 

Use this command to switch the Toolbar on and off. If the Toolbar is on, there is a mark in the menu.
The Toolbar gives you some buttons for the most comman functions like “open”.
See a description of all the buttons in the Toolbar.



Toolbar

To switch the Toolbar on and off, use “Toolbar” from menu “View”. (ALT,A,S).

Button Action
LuraWave shows the “Open-dialog” to search for files to open .

LuraWave shows the “Save-dialog” to choose some options before saving the 
frontmost picture.

Copies the frontmost picture into the clipboard.

Create a new window with the contents of the clipboard.

Zoomes in the frontmost window.

Zoomes out the frontmost window

Shows the directory of the LuraWave-Help-System.

Switches into the Help-Mode. Click into a button ore window if you like to 
know what it is for.

Shows the version of LuraWave for Windows



Command Status (Menu View)

Use this command to switch the statusbar on and off. If the statusbar is on, the menu is marked.
In the statusbar you can see a shortcut of the function of the button the mouse is over, the actual 
zoomfactor, the coordiantes of the mouse relative to the picture and the color of the pixel below the 
mouse.

See Statusbar for a further description.



Statusbar

The Statusbar is displayed at the lower border of LuraWave. You can switch it on and off with “Status” 
from the “View”-menu.
If you step thruh menu by ARROW-KEY you will see a short description of the menus function in the left 
part of the status bar.
If you click onto a button and hold the mouse down, you will see a descrition of the button. If you do not 
want to choose a command you have selected, drag the mouse out of the button while the mouse is still 
down. 

On the right side of the status bar you will see the coordinates of the mouse in relation to the picture and 
the RGB-values of the color below the mouse. 



Command New Window (Menu Window)

This command opens a new window and displays the same picture than the actual window. This feature is
to view different areas of a picture in detail. If you make changes in one window, this changes will take 
effect in all the window of that picture.
If you open a new window with this command, it will be shown in front and will get the active window.



Command Cascade (Menu Window)

Use this command to display the open windows in a stacked manner.



Command Tile Vertical (Menu Window)

Use this command to display the open windows in a vertical manner.



Command Tile horizontal (Menu Window)

Use this command to display the open windows in a horizontal manner.



Command Clean Up Symbols (Menu Window)

Use this command to clean up the symbols at the lower border of the LuraWave window. You can create 
symbols from windows if you click into the “to Symbol”-button.
If the lower part of the LuraWave window is occupied by a window, the symbols will not be visible.



Command 1, 2, ... (Menu Window)

Here you can choose one of the opne windows to become the frontmost. The frontmost one is marked.



Themes (Menu Help)

Use this command to get the directory of the Help-system.



Command Use Help (Menu Help)

Use this command to optain hints for the use of most commands.



Command Info (Menu Help)

With this command you will get the version of your copy of LuraWave.



Command context help 

If you click here, the mouse-arrow changes into a arrow with a question mark. Now you can click into 
any part of    LURAWAVEs windows and get help on this part.

Shortcut:
Keyboard: SHIFT+F1



Titlebar

You can find the titlebar at the upper border of LuraWave. It contains the name of the application.

To place the window, you can drag here.



Scrollbars

If a picture is not completely visible inside ist window, you can pan the picture with this scrollbars.



Command Resize (Menu System)

Here you can resize LURAWAVEs window. You can also resize by dragging the lower right edge of the 
window.



Command Drag (Menu System)

You can use this command to drag the window on the screen. You can also do that by dragging the 
titlebar.



Command Symbol (Menu System)

Use this command to shrink LuraWave into a symbol.

Shortcut

Mouse: Click into “Minimize” .
Keyboard: ALT+F9



Command Maximize (Menu System)

Use this command to expand the size of LuraWave to the whole screen.

Shortcut

Mouse: Click into “Maximize” .
Keyboard: STRG+F10.



Command Next (Menu Document)

Use this command to activate the next window.

Shortcut
Keyboard: STRG+F6



Command Previous (Menu Document)

Use this command to activate the previous window.

Shortcut
Keyboard: SHIFT+STRG+F6



Command Close (Menu System)

Closes the active window or dialog.



Command recreate (Menu System)

Use this command to get the application back from a symbol.



Command Switch To (Menu System)

Use this command to get a list of all active tasks (applications). You can switch to another task or close 
one.

Shortcut
Keyboard: STRG+ESC

The Task-List
Choose a task you like to switch to.

Switch to
Activates the choosen task.

Kill task
Closes the choosen task.

Cancel
Closes the task list.



Picture

This window displays a picture. You can zoom in,  zoom-out, save compressed  or uncompressed.



No help available



No help available



Formats

LWF LuraWave Wavelet Format
BMP Windows / OS2 Bitmap
PGM Portable Gray Map
PPM Portable Pixel Map
TIF Tagged Image File Format



Rate

Ratio of the filesize of the compressed and the uncompressed picture.



LWF-Quality

15-best possible quality
1 best compression ratio

During save, you can set the compression ratio directly.



Diskspace

Shows the amount of free space on the choosen volume.



Compression of pictures using wavelet transforms

LuraWave uses algorithms based on wavelet transforms.

This system has a lot of advantages compared to other algorithms:

wide range of compression ratios from lossless to very high rates (1 : 1000, lossy).
better quality with same filesize in comparisation to JPEG

exact defined compression ratio and filesizes

progressive load of data

compression with quality enhanced regions

quality based password protection of images 

Netscape-Plug In available

PhotoShop-Plug In available



Any LWF-Tool can decompress a protected image up to the free quality, which is specified before 
compression. For further improvement of the image the user has to give the correct password. In internet 
image databases this can be done automatically via CGI.



During compression the user can specify regions, which will be compressed with higher priority, i.e. with 
a better quality. When the image is transferred over a network these regions will appear first in the data 
stream. So they will become visible earlier, when the image is reconstructed progressively.
You can try this with the LuraWave Netscape Plug In (http://www.luratech.de)



LuRaTech GmbH

LuRaTech
Gesellschaft für 
Luft- und Raumfahrttechnologie
& Multimedia mbH

Rudower Chaussee 5 (im IGZ)
D-12489 Berlin
Tel:    ++49 (0) 30-63 92 63 70
Fax: ++49 (0) 30-63 92 63 71

e-mail: lurawave@luratech.de
www: http://www.luratech.de/



What is LuraWave

LuraWave will show the performance of a new, high power compression algorithms for data 
compression in comparisation to other popular compression shemes.

LuraWave includes algorithms for picture compression and decompression in lossless and lossy modes. 
Compression ratios range from 1:1,5 to 1:5 in lossless mode to 1:1000 in lossy mode.
Zoom and statistical functions are includes to allow easy comparisation.

LuraWave is able to handle the following formats:

LWF LuraWave Wavelet Format

BMP Windows / OS2 Bitmap

PGM Portable Gray-Map

PPM Portable Pixel-Map

TIF Tagged Image File Format

Further formats will follow in later version.



Command Zoom In (Menu Picture)

Use this command to zoom into the frontmost picture.

Shortcut

Toolbar:
Keyboard: GREY +



Command Zoom Out (Menu Picture)

Use this command to zoom out of the frontmost picture.

Shortcut

Toolbar:
Keyboard GREY -



Commad Info (Menu Picture)

Use this command to obtain som information about the frontmost window.



Preview

Click here to switch preview mode on and off.



HIDC_RADIO_PXM_BINARY

Click here to switch preview mode on and off.



HIDC_SPIN_LWF_LEVEL

Click here to switch preview mode on and off.



Compression of pictures

You can compress pictures by choosing “ Save” from the File-Menu and select the   LuraWave-Format   
(*.lwf)   to store the picture.  



Decompression of pictures

You decompress pictures by opening a file stored in LuraWave-Format (*.lwf) Decompression is done 
automatically.
You can store the picture uncompressed by using a other file format during save.






